Actor Matt Ward Cast As A Season 3 Villain
19 Aug. 2014

Actor Matt Ward Cast As A Season 3 Villain


Season 3 is getting another villain from the Green Arrow comic universe, as Entertainment Weekly has revealed that actor Matt Ward has been cast in the role of Simon Lacroix, also known as the villain Komodo. The Entertainment Weekly article also provides a little information on what we can expect from the character when he shows up this season, as well as giving some hints from Executive Producer Marc Guggenheim on how he will fit into the overall story of the third season:

On Arrow, he’s a deadly mercenary using the code name Komodo, who wreaks havoc in Starling City.

Komodo’s introduction comes as the show makes a move to connect the villains-of-the-week more closely to the overarching story. “Yes, he’s the villain-of-the-week for the second week of the show, but you’ll see that Team Arrow’s pursuit of him is part and parcel of a season-long storyline,” executive producer Marc Guggenheim says. “You’re going to know what happens to Komodo at the end of the episode, but it will be a little bit tied in better with the season-long mythology than villain-of-the-week episodes have done in the past.”

About the author

Tags

Related posts

Kevin Conroy Cast As Bruce Wayne In Crisis On Infinite Earths!
Kevin Conroy Cast As Bruce Wayne In Crisis On Infinite Earths!
August 4, 2019 - 0 comment
SDCC 2019 – Arrow Interview: Producer/Director James Bamford Previews Final Season
SDCC 2019 – Arrow Interview: Producer/Director James Bamford Previews Final Season
July 31, 2019 - 0 comment
SDCC 2019 – Arrow Interview: Rick Gonzalez Previews Wild Dog In Final Season
SDCC 2019 – Arrow Interview: Rick Gonzalez Previews Wild Dog In Final Season
July 31, 2019 - 0 comment
SDCC 2019 – Arrow Interview: David Ramsey On Green Lantern Hopes & Crisis on Infinite Earths In Final Season
SDCC 2019 – Arrow Interview: David Ramsey On Green Lantern Hopes & Crisis on Infinite Earths In Final Season
July 31, 2019 - 0 comment


Leave a Reply

* fields required